Pakete vom Rathaus Neukölln

Es ist wieder Zeit für einen Ich-will-verstehen-wie-Netzwerken-geht-Beitrag. Vor kurzem ist das Rathaus Neukölln im Freifunknetz online gegangen. Der Startschuss also, uns auch wieder mit unserem Freifunk zu beschäftigen. Warum? Weil Freifunken einfach total toll ist. Eigentlich wollte ich hier nur beschreiben, wie wir unsere kleine Nanostation, mit der man sich per Richtfunk mit anderen gleichartigen Geräten verbinden kann, einrichten und etwas über Meshing schreiben. Ich stellte aber fest, dass ich erstmal verstehen musste, wie Pakete überhaupt verschickt werden. Der Artikel enthält also einen echten Turning Point^^ (Vielleicht sollte der Laie meinen ersten Artikel lesen, sonst könnte der erste Teil etwas verwirrend sein)

Eigentlich sollte es so laufen:

  1. Nanostation mit dem Rathaus verbinden
  2. Nanostation mit unserem Freifunkrouter verbinden

Die Nanostation mit dem Rathaus zu verbinden war so einfach, wie es uns auf der Mailingliste beschrieben wurde. Auf dem Rathaus wird ein Access Point betrieben und die Nanostation kann sich mit diesem einfach als Client verbinden. Die Nanostation mit unserem Freifunkrouter zu verbinden hat uns schon mehr Kopfzerbrechen bereitet.  Zur Erinnerung: ein Router ist dazu da mehrere Netzwerke miteinander zu verbinden. Der letzte Stand war, dass auf unserem Freifunkrouter 4 Netze konfiguriert sind (unser Freifunkunternetz für die Nachbarn und Gäste, 2 Freifunkunternetze für Ad-hoc-WLAN-Verbindungen zu anderen Routern und unser Zuhausenetzwerk). Normalerweise verbindet sich der Router per WLAN mit anderen Freifunkroutern, aber mit der Nanostation geht das nicht. Die hat nämlich nur zwei Bauteile: Eine WLAN-Antenne und einen Netzwerkanschluss und die WLAN-Antenne ist schon besetzt, weil die sich ja mit dem Rathaus verbinden soll. Bleibt noch der Netzwerkanschluss. Binco meinte dann, wir machen das so:

Wir richten auf dem Freifunkrouter ein kleines Freifunknetz für die Nanostation und den Freifunkrouter ein. Dazu musste der Router so konfiguriert werden, dass einer der Netzwerkkabelplätze nicht mehr zum dhcp Interface gehört sondern zu einem Neuen, wir haben es rhnk genannt. Dazu haben wir auf dem Router  VLANs eingestellt, das kam mir total spanisch vor und was soll das kleine t in der options port Zeile? Ich wusste, der Binco hatte mir schonmal erklärt was Switches und Hubs sind und wie das mit IP-und MAC-Adressen zusammen hängt, aber ich habe es wieder vergessen… Fragen über Fragen, nur nochmal nachgefragt hatte ich nicht…und wer nicht fragt bleibt dumm (╯°□°)╯︵ ┻━┻

Leider gingen nicht alle Pakete durch das Freifunk-VPN, sondern direkt über unsere Internetleitung. Das war total doof und wir konnten das Problem nicht beheben, aber zum Glück gibt es großartige Freifunkmenschen, die bis weit nach Mitternacht versucht haben den Fehler zu finden. Es stellte sich heraus, dass zwei Firewallregeln nicht gesetzt wurden.

Das Dumme war nur, der Router vergaß die neuen Einstellungen bei jedem Neustart wieder.

:/

Hier ein Bild von allen Geräten und wie sie zu diesem Zeitpunkt zusammen hingen.

netzwerk_v1Wir haben dann eine Nacht darüber geschlafen und uns dann entschieden einen anderen Weg zu gehen. Bei dem müssen wir uns nicht mit der Freifunkfirewall auseinandersetzen, unsere komplette Infratstruktur wird etwas übersichtlicher und wir können alle unsere Geräte auch aus unserem internen Netz erreichbar machen (außerdem konnte ich Binco über VLANs und Pakete verschicken ausquetschen *hrhrhr*).

Hier ein Bild von der Zielarchitektur:

netzwerk_v2Auf Tony, unserer Firewall, haben wir zuerst das Freifunk-VPN eingerichtet. Danach haben wir ein Freifunkinterface und ein neues VLAN für unsere Freifunkgeräte angelegt. Eine Firewallregel legt fest, dass alle Pakete, die über das Freifunk-Interface auf Tony ankommen, schnurstracks ins Freifunk-VPN weitergeleitet werden. Das Freifunk-Interface auf Tony ist im Prinzip dasselbe, was auf dem Freifunkrouter ein Interface ist und was ich im letzten Post schon beschrieben hatte. Es definiert ein kleines Netzwerk, das einem Gerät zugeordnet werden kann und in unserem Fall  genau einem Netzwerkanstöpselplatz von Tony, auf dem das Freifunk-VLAN konfiguriert ist.

Was hat es denn nun mit diesen VLANs auf sich? Die kamen ja schon oben vor, als wir ein neues Interface für den einen Netzwerkanstöpselplatz auf dem Freifunkrouter angelegt haben.

VLAN heißt ausgeschrieben Virtual Local Area Network. Statt VLANs anzulegen könnte man auch pro Netzwerk ein Kabel verlegen. Soviele Kabel führen aber zu Kabelsalat und außerdem hat Tony gar nicht soviele Netzwerkanstöpselplätze. Der Trick ist also VLANs zu definieren und Pakete, die zu einem VLAN gehören zu markieren, das wird auch tagging genannt.

Die meisten Geräte in einem Netzwerk sind über einen Switch miteinander verbunden. Ein Switch ist ein Netzwerkgerät, an das man mehrere Netzwerkkabel anschließen kann. Pakete, die an einem Port ankommen, werden an einem anderen Port wieder rausgeschickt. Manche Leute (Binco) behaupten, Switches seien dumm. Noch dümmer wären nur Hubs, die Pakete, die an einem Port ankommen, einfach an allen anderen wieder raushauen. Ein normaler Switch weiß welche Geräte an welchen Ports angeschlossen sind, das merkt er sich nämlich, wenn sogenannte ARP-Pakete vorbeikommen. In diesen Paketen steht eine MAC-Adresse und diese ist der eindeutige Name einer Netzwerkkarte. Will mein Computer z.B. ein Paket an eine bestimmte IP-Adresse im selben Netz verschicken, fragt er erstmal alle Geräte im Netzwerk nach der MAC-Adresse zu dieser IP. Gibt es ein Gerät mit der angefragten IP, schickt dieses eine Antwort mit seiner MAC-Adresse zurück. Kommt das Paket beim Switch vorbei merkt der sich die MAC-Adresse und den Port, wo es rauskam. Danach schickt mein Computer das eigentliche Paket los und schreibt ran, zu welcher MAC-Adresse es muss. Kommt ein solches Paket beim Switch an, leitet der es über den richtigen Port weiter.

switchSchlaue Switches unterstützen VLANs und das bedeutet Folgendes: Wenn ein getaggtes Paket ankommt, weiß der Switch nicht nur, auf welchem Port das Paket wieder rausgeschickt werden muss. Es bedeutet auch, dass der Switch ein Paket tagged, wenn es über einen bestimmten Port reinkommt, bevor er es weiter schickt bzw. er kann den Tag entfernen, bevor er es weiterschickt .

Ob der Switch an einem Port mit getaggten Paketen umgehen muss, wird durch ein t angegeben. (Aha, was man nämlich über unseren Freifunkrouter noch wissen muss, ist, dass er einen eingebauten Switch hat, der VLANs unterstützt. Manoman!)

Den Wohnzimmerfreifunkrouter haben wir nochmal neu geflashed und alles auf Anfang zurück gesetzt. Dann haben die WLANse so wie beim letzten Mal mit einer Bridge eingerichtet. Man kann das übrigens auch alles über das Webinterface machen. Vielleicht schreib ich im Wiki mal was dazu. Nur eine Sache ist anders: Vorher wurden an den Netzwerkanstöpselplätzen (dem Wohnzimmerrouterswitch wie ich nun weiß) auch Freifunk-IPs verteilt. Jetzt gehören die aber alle mit zum Freifunk-VLAN, das auch auf Tony konfiguriert ist.

Pakete vom Rathaus verschicken funktioniert also so:

Wohnzimmerrouter: Hallo Leute! Ich hab hier übrigens Internet :)
Rathaus Neukölln: Hey Wohnzimmerrouter! Ich hab hier ein Paket was ins Internet muss, zeig dem mal wos lang geht!
Wohnzimmerrouter: Klaro! Hey Switch, schick das Paket bitte mal an Tony weiter. Danke :)
Switch: *vlan-tag-drauf-pack* TONY! PAKET FÜR DICH!
Das Paket kommt durch die Freifunkinterfacetür bei Tony rein, Tony sieht das große VLAN-tag und das Paket ist vollkommen chancenlos, bekommt einen kräftigen Schubs und fliegt durch die Freifunkvpntür wieder raus.
- Kurze Pause –
Es klingelt an der Freifunkvpntür.
Antwort-Paket: *räusper* Tschuldigung ich möchte gern hier durch.
Das Antwort-Paket zeigt auf die Freifunkadresse wo es gerne hinmöchte. Tony guckt grimmig und verpasst dem Paket einen VLAN-tag und schiebt es Richtung Freifunkinterfacetür.
Switch: *vlan-tag-abreiß* WOHNZIMMERROUTER! PAKET FÜR DICH!
Wohnzimmerrouter: Oh danke. Ach Antwortpaket, du bist es. Das Rathaus freut sich bestimmt, dass du kommst. Hier gehts lang :)
Rathaus Neukölln: Da bist du ja endlich! Du musst zu dem Freifunknutzer da, der wartet schon ewig auf dich.

Alles in allem bedeutet das Ganze, dass wir jetzt nicht nur unseren Nachbarn unser Internet zur Verfügung stellen sondern potentiell auch allen, die sich am Freifunk am Rathaus Neukölln (oder irgendwo in Berlin) anmelden und umgekehrt, falls unser Internet ausfällt können wir immer noch über das Freifunknetz Twitter und Co erreichen. Ich sags ja, Freifunk ist total toll n_n

Falls ich etwas falsch beschrieben habe, würde ich mich über Hinweise freuen.

Der Vollständigkeit halber hier noch die Anfangskonfiguration, wie sie unserer Meinung nach eigentlich hätte funktionieren müssen:

Ein Auszug aus der /etc/config/network:

config switch                                  
        option name 'switch0'                  
        option reset '1'                       
        option enable_vlan '1'                 
                                               
config switch_vlan                      
        option device 'switch0'         
        option vlan '0'                 
        option ports '0t 2 3 4'         
                                        
config switch_vlan                      
        option device 'switch0'         
        option vlan '1'                 
        option ports '0t 1'  

config interface 'dhcp'                        
        option ifname 'eth0.0'                 
        option type 'bridge'                   
        option proto 'static'           
        option ipaddr '104.205.0.49'    
        option netmask '255.255.255.240'
        option ip6assign '64'

config interface 'rhnk'                 
        option ifname 'eth0.1'          
        option proto 'static'           
        option ipaddr '104.205.0.77'    
        option netmask '255.255.255.252'

Zuerst wird dem Switch Bauteil mit option enable_vlan ‘1’ mitgeteilt, dass es jetzt VLAN machen soll. Und danach werden die beiden VLANs angegeben. Mit option ports legt man fest, welche Netzwerkanstöpselplätze zum VLAN gehören. Das Erste hat die Ports zwei, drei und vier, das zweite VLAN den ersten Steckplatz. Man beachte das kleine t. (Übrigens: Wo man beim Portzählen anfängt, war für mich etwas verwirrend. Im OpenWrt Wiki gibt es eine allgemeine Seite über die Switch-Config und dann nochmal eine mit der wirklichen Portbelegung für unseren Router).  Für das interface dhcp muss die option ifname in eth0.0 geändert werden (das erste VLAN) und das neue Interface rhnk wird dem zweiten VLAN eth0.1 zugewiesen (ifname bezeichnet die Netzwerkanstöpselplätze). Das Interface rhnk bekommt die IP ‘104.205.0.77’ und netmask ‘255.255.255.252’ gibt an, dass vier IP-Adressen zu dem Netzwerk gehören. Die haben wir auf der Freifunkseite für uns beantragt. Vom Freifunkrouter kann die Nanostation jetzt erreicht werden, aber damit der Freifunkrouter Pakete von der Nanostation durchlässt, mussten wir das interface rhnk noch mit in die Firewallzone aufnehmen. Wie zwei Freifunkerspezialisten herausgefunden haben, wurden zwei Firewallregeln nicht gesetzt. Mit
ip rule add pref 20001 iif eth0.1 unreachable
ip rule add pref 20000 iif eth0.1 lookup olsr-default
auf der Console der Router kann man die hinzufügen. Leider hielten die aber wie gesagt nur bis zum nächsten Neustart.

#freifunk Router (teilweise) demystified

Netzwerken war für mich immer irgenwie langweilig. Ich hab programmieren gelernt und und alles was vor der dem Netzwerkanschluss an meine Computer passierte, hatte mich nicht interessiert. Wichtig war nur, dass ich Internet hatte.
Das erste Mal, dass ich ein Freifunknetz sah, war im Tante Horst und ich fand es total klasse einfach Internet zu haben ohne nach einem Passwort fragen zu müssen oder etwas zu bezahlen. Ich bin sowieso dafür, dass jeder Mensch einfach freies Internet bekommt, Freifunk ist aber noch mehr. Hier geht es darum ein eigenes Netz aufzubauen, das unabhängig ist von kommerziellen Anbietern. Das ganze läuft dezentral und lebt durch die Community, man kann auch eigene Services anbieten, die selbst dann erreichbar sind, wenn das “richtige” Internet weg ist. Das ganze fand ich sehr sympatisch, aber das jetzt selber bereitzustellen?

Lange Zeit hat sich bei mir nichts in die Richtung bewegt, aber letztes Jahr war ich mit Binco und Thomas beim 30c3, die Freifunker Berlin waren auch da und wenn man schonmal da ist, kann man sich ja informieren. Nachdem uns die Grundlagen erklärt wurden, haben wir auch gleich einen Router gekauft und noch vor Ort geflashed. Das heißt, wir haben die Herstellersoftware auf dem Gerät durch eine von den Freifunkern programmierte ausgetauscht. Zu dem Zeitpunkt habe ich nix von dem verstanden, was ich gemacht habe. Es gab da Devices und Interfaces mit seltsamen Namen und ich hatte keine Peilung was mit was zusammen hängt. Eine Fehlersuche war für mich zu dem Zeitpunkt unmöglich, weil ich einfach nicht verstand, wie ein Router so tickt. Das war schlecht, denn das Konfigurieren mit dem Assistenten in der Bentzeroberfläche wollte einfach nicht funktionieren.

Soweit zur Vorgeschichte. Ich wollte unbedingt, dass wir einen eigenen Zugang zum Freifunknetzwerk anbieten und dadurch die Welt ein bisschen besser machen, also hab ich den Thomas und vor allem den Binco ausgefragt, wie der ganze Netzwerkkram funktioniert. Und jetzt schreib ich hier auf wie unser Router funktioniert, denn das ist der kleine Teil, den ich glaube einigermaßen verstanden zu haben und den ich nicht wieder vergessen will.

image

Das ist unser WLAN Router. Er hat zwei Antennen und fünf Plätze für Netzwerkkabel. Ein Router ist dazu da, mehrere Netzwerke miteinander zu verbinden. Normalerweise ist eines der Netzwerke das große Internet und das andere ist das Zuhausenetzwerk, wo man sich mit seinem Computer oder seinem Handy anschließen kann. Durch die Magie des Routers kann ich dann z.B. Daten von meinem Computer in das andere Netzwerk Internet senden und von da Empfangen.

routermagie

Die nächste Frage also: Wie funktioniert die Magie in einem Router? Innerhalb eines Netzwerks haben alle Geräte eine IP, das ist eine Nummer, die das Gerät identifiziert. Die möglichen Nummern sind immer für ein Netzwerk definiert. Der Router ist Teil eines jeden Netzwerks, das er miteinander verbindet und er kennt jede mögliche Nummer aus den verbundenen Netzwerken. Jedes Routerbauteil über das ich mich mit einem Computer oder Handy zum Router verbinden kann, hat einen Namen und für jedes dieser Bauteile kann ein Netzwerk konfigureirt werden. In unserem Fall haben die beiden WLAN Antennen die Namen radio1 und radio2, ein Steckplatz für ein Netzwerkkabel  hat den Namen eth1 und das Routerbauteil wo man vier andere Netzwerkkabel anschließen kann, heißt eth0. Die beiden WLAN Antennen sind speziell. Die können nämlich jeweils mehr als ein WLAN Netzwerk verteilen.

Die Standardkonfiguration unseres Freifunkrouters hätte eigentlich folgendes machen müssen:

– zwei WLAN Netzwerke auf radio0 (Freifunk auf einer Frequenz)
– zwei WLAN Netzwerke auf radio1 (Freifunk auf einer anderen Frequenz)
– ein Netzwerk auf eth1 (das Internet)
– ein Netzwerk auf die eth0 (Zuhausenetzwerk)

routerbauteile

Hat er aber nicht, deswegen sind Binco und ich in die cbase zum Treffen der Berliner Freifunker gefahren. Dort hat man uns am Userinterface vorbei auf der Konsole des Routers die Netzwerke eingerichtet. Dort habe ich auch angefangen zu verstehen was Interfaces in einem Router sind. Die enthalten nämlich Informationen über die einzelnen Netzwerke und man kann sie mit einander verbinden.

philippsconfig

Im Router gab es jetzt:
-ein Interface mit dem Namen wireless0 für radio0
-ein Interface mit dem Namen wireless1 für radio1
-ein Interface mit dem Namen dhcp
-ein Interface mit dem Namen wan für den Netzwerkanstöpselplatz eth1
-und ein Interface mit dem Namen lan für die Zuhausnetzwerkanstöpselplätze an eth0

Es gibt eine Datei /etc/config/network auf dem Router in der das konfiguriert ist. Hier ein Auszug:

config interface 'wireless0'
   option dns '2002:d596:2a92:1:71:53:: 2002:5968:c28e::53 88.198.178.18 141.54.1.1 212.204.49.83 8.8.8.8 8.8.4.4'
   option ip6assign '64'
   option netmask '255.0.0.0'
   option ipaddr '104.205.0.12'
   option proto 'static'

config interface 'wireless1'
   option dns '2002:d596:2a92:1:71:53:: 2002:5968:c28e::53 88.198.178.18 141.54.1.1 212.204.49.83 8.8.8.8 8.8.4.4'
   option ip6assign '64'
   option netmask '255.0.0.0'
   option ipaddr '104.205.0.14'
   option proto 'static'

config interface 'dhcp'
   option type 'bridge'
   option ipaddr '104.205.0.49'
   option netmask '255.255.255.240'
   option ip6assign '64'
   option proto 'static'

config interface 'lan'
   option ifname 'eth0'
   option type 'bridge'
   option proto 'static'
   option ipaddr '192.168.1.1'
   option netmask '255.255.255.0'
   option ip6assign '60'

config interface 'wan'
   option ifname 'eth1'
   option proto 'dhcp'

wireless0 und wireless1 sind zwei Netzwerke, die nur aus einem Gerät bestehen, nämlich dem Router selbst. Einmal hat der Router die IP 104.205.0.12 und einmal 104.205.0.14. Diese IPs gehören zum großen Freifunknetzt und sie werden später zum Meshen benutzt. Das bedeutet unser Freifunkrouter verbindet sich mit anderen Freifunkroutern, die in der Nähe sind, per Funk. Es gibt zwei, weil der Router auf zwei verschiedenen Wlan Frequenzen senden kann. Warum und weshalb verstehe ich noch nicht, auf jeden Fall kann der Router sich darüber mit anderen Geräten im Freifunknetz verbinden.

Im Netzwerk dhcp hat der Router selbst die IP 104.205.0.49 und es gehören 15 weitere IPs zu diesem Netzwerk was durch option netmask ‘255.255.255.240’ festgelegt wird. Das heißt der Teil gehört auch noch zum großen Freifunknetz. Man kann also sagen, dass drei kleine Unternetze aus dem Freifunknetz jetzt auf unserem Router konfiguriert sind. Das ist fest und gilt für die ganze Welt. Krass oder? Für das dhcp Interface ist auch noch wichtig, dass es eine Bridge ist. Das bedeutet alle Daten, die da ankommen werden einfach weitergeleitet.

Diese drei Netze sind noch keinem Routerbauteil zugeordnet. Das ist bei den Interfaces lan und wan anders. Die Zeile option ifname verbindet diese Interfaces jeweils mit Netzwerkanstöpselplätzen (eth0 bzw. eth1). Jetzt sind also noch zwei Routerbauteile übrig: Wie die beiden Antennen radio0 und radio1 mit den Netzwerken wireless0, wireless1 und dhcp verbunden werden, wird in einer anderen Datei geregelt nämlich /etc/config/wireless. Für das Interface wan gibt es im Moment noch die besondere Zeile option proto ‘dhcp’. DHCP ist ein Service, der dafür sorgt, das Geräte die sich einem Netzwerk anschließen eine eindeutige Nummer, ihre IP, bekommen. Wir haben für den Router jetzt vier IP Adressen für vier schiedene Netze statisch festgelegt. Für das fünfte Netz das Internet sagt die Zeile, dass der Router automatisch eine IP Adresse zugewiesen bekommt. Das war am Anfang etwas verwirrend, weil wir ja auch ein Interface mit dem Namen dhcp haben. Aber: Das ist eben nur ein Name, es könnte auch blakeks oder supertollesvirtuellesinterface heißen. Das Interface hat den Namen bekommen, damit schlaue Leute wissen, dass der Router auch IP Adressen aus unserem kleinen Freifunkunternetz vergeben kann, nämlich z.B. an mein Handy und an meinen Computer, wenn sie sich mit dem Freifunkrouter verbinden.

Eine ganz wichtige Komponente hab ich noch nicht erwähnt: Die Firewall. Die sorgt nämlich dafür das Daten aus einem Netz in ein anderes dürfen oder eben nicht. Als die dann mit etwas Hilfe von der Freifunkmailingliste auch noch richtig eingestellt war, war es endlich soweit: Mein Handy konnte sich mit dem Freifunknetz verbinden und ich konnte surfen.

Jetzt ging es an das Finetuning. Wir wollte nämlich, dass die vier Netzwerkstöpselplätze auch zum Freifunknetz gehören und wir wollten, dass der Router immer über die selbe IP Adresse aus unserem Zuhausenetzwerk erreichbar ist. Also haben wir das Interface dhcp dem Routerbauteil eth0 zugewiesen (all credits to Binco) und das lan Interface gelöscht, weil wir es ja jetzt nicht mehr brauchten, außerdem haben wir dem wan Interface eine statische IP verpasst, damit wir ihn auch trotzdem noch aus unserem Zuhausenetzwerk erreichen können.

routerfinalconfig

Auszug /etc/config/network:

config interface 'wireless0'
	option dns '213.73.91.35.53'
	option ip6assign '64'
	option netmask '255.0.0.0'
	option ipaddr '104.205.0.12'
	option proto 'static'

config interface 'wireless1'
	option dns '213.73.91.35'
	option ip6assign '64'
	option netmask '255.0.0.0'
	option ipaddr '104.205.0.14'
	option proto 'static'

config interface 'dhcp'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'static'
	option ipaddr '104.205.0.49'
	option netmask '255.255.255.240'
	option ip6assign '64'

config interface 'wan'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr '192.168.42.5'
	option netmask '255.255.255.0'
	option gateway '192.168.42.1'
	option dns '213.73.91.35'

Update: Ich hab in der config oben in den Zeilen option dns noch den DNS Server geändert, damit die Anfragen nicht mehr zu google gehen.

Zuf Vollständigkeithalber, hier nochmal das Bild von dem, was der Assistent eigentlich hätte machen müssen. Der Unterschied ist, das wireless1 und wireless2 hier nicht über ein virtuelle Interface dhcp gebridged sind, sondern es nochmal ein kleines extra Freifunkunternetz gibt.

routerdefaultconfig

Auszug /etc/config/network

config interface 'wireless0'
   option dns '2002:d596:2a92:1:71:53:: 2002:5968:c28e::53 88.198.178.18 141.54.1.1 212.204.49.83 8.8.8.8 8.8.4.4'
   option ip6assign '64'
   option netmask '255.0.0.0'
   option ipaddr '104.205.0.12'
   option proto 'static'

config interface 'wireless1'
   option dns '2002:d596:2a92:1:71:53:: 2002:5968:c28e::53 88.198.178.18 141.54.1.1 212.204.49.83 8.8.8.8 8.8.4.4'
   option ip6assign '64'
   option netmask '255.0.0.0'
   option ipaddr '104.205.0.14'
   option proto 'static'

config interface 'wireless0dhcp'
   option type 'bridge'
   option proto 'static'
   option ipaddr '104.205.0.49'
   option netmask '255.255.255.240'
   option ip6assign '64'

config interface 'wireless1dhcp'
   option type 'bridge'
   option proto 'static'
   option ipaddr '104.205.0.64'
   option netmask '255.255.255.240'
   option ip6assign '64'

config interface 'lan'
   option ifname 'eth0'
   option type 'bridge'
   option proto 'static'
   option ipaddr '192.168.1.1'
   option netmask '255.255.255.0'
   option ip6assign '60'

config interface 'wan'
   option ifname 'eth1'
   option proto 'dhcp'

Ich hab das Gefühl ne Menge Neues gelernt zu haben. Aber wie das so ist mit neuem Wissen: Man erfährt auch von vielen Dingen, von denen man vorher gar nicht wusste, dass es sie überhaupt gibt oder mit dazu gehören. Ich hab noch ganz viele Fragezeichen, was Routing betrifft und die ganzen anderen Konfigurationsdinge auf dem Router, dann gibt es noch Switches, VPN, Meshing, DHCP, OSI-Schichten, WLAN-Frequenzen oder Datendurchsatz wovon ich jetzt eine Idee habe, aber immer noch “em, em, em” mache und nicht verstehe wie die Dinge zusammen hängen. Falls ich hier irgendwas falsch beschrieben habe, würde ich mich über eine Info freuen :)

(inspired by Fiona)

30c3

3. Tag 4 Uhr morgens:
Das Gefühl ein Alien zu sein dauerte ungefähr einen Tag. Es gibt hier so viel Großartiges und mittlerweile fühl ich mich hier so wohl, ich kann das gar nicht beschreiben. Ich freue mich über die Fluggeräte, die hier rumfliegen und den elektrische Auto mit dem Dino als Fahrer, das hier ferngesteuert durch die Gegend düst. Ich will wissen wie die ganzen LEDKonstrukte funktionieren und ich schüttel den Kopf über Politik und weiß, dass alle anderen hier meine Meinung teilen. Jedes mal wenn eine Rohrpost durch die Seidenstraße fährt, denk ich mir dass is so krass awesome hier, warum ist das mein erster Kongress und warum bin ich nicht schon früher her gekommen? Die Antwort ist, dass ich mich nicht getraut habe und wenn Thomas und Binco nicht hier wären, hatte ich wieder den Stream geschaut. Ich bin noch immer nicht mutig genug die Leute neben den Dingen, die ich interessant finde zu fragen wie sie funktionieren, aber vielleicht kriege ich das morgen besser hin :)

Das war’s erstmal

So! Meine Reise ist vorbei. Nach fast 8 Monaten bin ich wieder in Deutschland. Ich hab meine Mitbewohner gedrückt, schnell ein paar Sachen gepackt und bin jetzt auf dem Weg zu meiner Schwester. Der Weihnachtsstress hat mich gleich erwischt und danach geht’s zu meinem ersten Congress irl, da werde ich gar keine Zeit für Jetleg haben.
Was kann ich zum Abschluss sagen? Eins auf jeden Fall: Egal was jetzt noch passiert, das war mein Jahr! Ich habe Zeit mit wunderbaren Menschen verbracht und Orte gesehen und Dinge getan, von denen ich vor einem Jahr nie gedacht hätte, das ich das schaffe. Eigentlich geht es nur darum, nicht zu lange nachzudenken, sondern zu machen: tauchen gehen, einen Berg besteigen, alleine durch ein fremdes Land reisen. Ich weiß, dass ich super viel Glück habe, dass ich diese Reise machen konnte und ich möchte jedem danken, der mich immer wieder anschubste und Mut machte, der mir geholfen hat und zur Verwirklichung der Reise beitrug. DANKE! DANKE! DANKE!
In Kanada hab ich mit Freunden einen Roadtrip gemacht, danach bin ich von Vancouver nach Miami gecouchsurft um im Anschluss mit dem Auto durch Florida von Hotel zu Hotel zu fahren. Alle drei Reisearten hatten ihre Vor- und Nachteile. Es gibt praktisch nichts Schöneres als gemeinsam mit Menschen die man mag vorher Ungesehenes zu bestaunen und nichts Spannenderes als mit Fremden Reisegeschichten zu teilen und sich ihre Heimatstadt zeigen zu lassen auch wenn man etwas Mut aufbringen muss sie zu treffen. Die Autotour durch Florida wahr wohl die schwerste Zeit. Wenn einen niemand erwartet und man nicht automatisch mit Leuten ins Gespräch kommen kann, hat man sehr viel Zeit mit sich selbst und es ist einfach sich einsam zu fühlen. Es ist aber auch eine gute Lehre sich selbst genug zu sein, das Alleinesein zu genießen und zu machen was man möchte ohne auf andere achten zu müssen. Den größten Schatz, den ich mitnehme, ist mehr Selbstvertrauen und das Bewusstsein das ich schaffen kann, was ich mir vornehme, wenn ich nur los gehe. Der erste Schritt ist der schwerste, aber es gibt auf dem Weg so viele Großartigkeiten und neue Möglichkeiten, die sich auftun und es ist so schön Momente einfach zu genießen.
Ob ich hier weiter schreibe, weiß ich noch nicht. Ich hab ja angefangen, weil ich nicht so vielen Leuten Mails darüber schicken wollte, was ich mache und wo ich bin :p
Wenn ich keine anderen Themen finde, gehts spätestens zur nächsten Reise weiter!

Key West

Hier sind die Urlauber entweder uralt, zu zweit total verliebt, mit Kleinkindern im Familienurlaub oder alles zusammen und schwul. Hier flattern mehr Regenbogen- und Piratenfahnen als amerikanische Flaggen. Es fühlt sich nach einem schönen Safe Space an, wo ich mich sogar traute abends zwei Gläser Wein zu trinken und zwanzig Minuten nach Hause zu schlendern. Kein komisches rumgestelze wie in Miami.
Es ist sehr karibisch hier. Zum Sonnenuntergang trifft sich die Stadt am westlichen Pier, wo Feuerkünstler ihre Show machen und Klampfenspieler alle paar Meter ein Liedchen zum Besten geben, während die Segelboote vor dem goldenen Horizont kreuzen. Alles sehr ramontisch, ein bisschen bedaure ich ja hier alleine zu sein obwohl ich bezweifel, dass jemand mein zielloses Rumgewander am ersten Tag lange ausgehalten hätte. Die Häuser erinnern mich sehr an Charleston, nur hier ist alles etwas kleiner.
Ich hab zwei Frauen mit einem Papagei auf der Schulter gesehen, einen okulelespielenden Darth Vader, ein Typ auf einem im hell beleuchteten Fahrrad, das er scheinbar nur zum Spaß die Straße mit Musik beschallend entlang fuhr. Und ich habe einen schwarzen Hund mit in Glitzer lakierten Krallen gesehen. Überhaupt glitzert es hier überall, der Glitter liegt auf dem Bürgersteig und sogar der Eingang des Tauchladens glitzerte zur Begrüßung.
Tauchen war phantastisch. Tony der Tauchlehrer hat mir gleich als erstes einen Seestern auf die Hände gelegt 0_O dann hat er was Seesternähnliches unter einem Stein hervor geholt und mir ebenfalls in die Hand gelegt. Ich hab einen Hummer und eine Qualle angefasst und es gab ganz viele Fische zu sehen. Einmal hab ich Tony kurz verloren und war ganz alleine, weil ich einem hübschen Fisch beobachtete und er weiter schwamm. Mir blieb nichts anderes übrig, als zu warten bis er mich wieder findet. Mein nächstes Ziel ist also ein Tauchschein, damit ich beim nächsten Mal alleine weiß wo vorne und hinten ist :)

image

image

image

image

image

image

image

image

image

image